Recent Forum Issues!

Discussion in 'Site News & Announcements' started by zathros, Dec 14, 2013.

  1. zathros

    zathros -----SENIOR---- Administrator Moderator

    Joined:
    Apr 6, 2013
    Messages:
    7,682
    Likes Received:
    3,524
    announce1Help is on the way, the Calvary has arrived. We also have some big plans ahead, so things are looking up, and the future looks really really bright, Time to gets some shades fellow modelers!idea1
  2. spaceagent-9

    spaceagent-9 Right Hand Man and Confidant Moderator

    Joined:
    Jul 11, 2013
    Messages:
    1,859
    Likes Received:
    1,206
    thanks moderators!
  3. Revell-Fan

    Revell-Fan Co-Administrator Administrator Moderator

    Joined:
    Aug 1, 2009
    Messages:
    6,047
    Likes Received:
    3,686
  4. ASC Mclaren

    ASC Mclaren Member

    Joined:
    Nov 19, 2011
    Messages:
    765
    Likes Received:
    209
  5. spaceagent-9

    spaceagent-9 Right Hand Man and Confidant Moderator

    Joined:
    Jul 11, 2013
    Messages:
    1,859
    Likes Received:
    1,206
    yer a re-boot alternative universe mega-morph of all of them!!!! kind of like the super skrull in fantastic 4
  6. Revell-Fan

    Revell-Fan Co-Administrator Administrator Moderator

    Joined:
    Aug 1, 2009
    Messages:
    6,047
    Likes Received:
    3,686
    Well, it was supposed to be "The Z-Team", but I was unable to upload the correct pic..!

    :mrgreen::mrgreen::mrgreen: :thumb::thumb::thumb: :mrgreen::mrgreen::mrgreen:
  7. zathros

    zathros -----SENIOR---- Administrator Moderator

    Joined:
    Apr 6, 2013
    Messages:
    7,682
    Likes Received:
    3,524
    We need more in this women. They add something special to the forum. "Keds Girl LaLa" was a perfect example. An incredible modeler, fun, and just plain nice to have around.
  8. mrmyster

    mrmyster Anla-shok

    Joined:
    Jan 8, 2012
    Messages:
    20
    Likes Received:
    2
    is this why thumbs are missing?

    i'm cruising the forums [again] and notice a lot of the thumbnails aren't showing up. is the technical issue you mention the cause? or are there gremlins on my end?

    thanx in advance