Marklin Z scale 8800 locomotive

Discussion in 'N / Z Scale Model Trains' started by ecologito, May 9, 2008.

  1. ecologito

    ecologito New Member

    Joined:
    May 9, 2008
    Messages:
    5
    Likes Received:
    0
    Help me with my 8800 locomotive

    Hi,

    My father gave me a few years ago this train in a box and never really care about it until yesterday, a friend asked me about it and we search on the internet.

    Looking at the box and after finding a few websites this is what I got

    z220.org Märklin 1972 catalogue pages five and six

    The 8800 Locomotive engine that actually shipped with the Mini-club 8900 and I think this s one of the 1972 sets.

    I tried to make it work, I have some knowledge about motors ( I build my own brushless motors for RC planes). I would like to know if there is a place where I could get parts to get it fixed. I think I need new brushed for it.

    Any help would be appreciated, I wil ltry to post pictures of the kit I have.
  2. logicman

    logicman Greybeard

    Joined:
    May 1, 2008
    Messages:
    542
    Likes Received:
    0
    Greetings, ecologito.

    (Should that be saludos?)

    Here's a link to loads of z-scale information, clubs, shops etc.

    Do it Yourself in Z-scale: More Information

    Please come back, there are lots of people here who can help and advise you.


    :wave:
  3. ecologito

    ecologito New Member

    Joined:
    May 9, 2008
    Messages:
    5
    Likes Received:
    0
    pictures

    Here a a few pictures of my train. I know a lot of people here know their biz and I don't so please tell me if I was wrong on what I have here :wave:

    Attached Files:

  4. shaygetz

    shaygetz Active Member

    Joined:
    May 2, 2003
    Messages:
    3,877
    Likes Received:
    0
  5. ecologito

    ecologito New Member

    Joined:
    May 9, 2008
    Messages:
    5
    Likes Received:
    0
    Thanks I took my locomotive and motor apart, it seems like I need new brushes for the motor since it runs erratically. I am not sure where could Send it back to get fixed.
  6. steamhead

    steamhead Active Member

    Joined:
    Apr 17, 2005
    Messages:
    2,530
    Likes Received:
    0
    Hi....You didn't say how much that little engine was run before it was put away. Has it had much use..? To wear out the brushes would take quite a bit of running. Your problem might be as simple as dirty track. Try cleaning it AND the wheels on the locomotive. Then give it a try...
    Good luck..!!
  7. ecologito

    ecologito New Member

    Joined:
    May 9, 2008
    Messages:
    5
    Likes Received:
    0
    I have no idea, my dad bough it 35+ years ago. I don't think it has been run a lot. I oiled everything but I will clean everything and give it another try.
  8. hmas

    hmas Member

    Joined:
    Mar 22, 2007
    Messages:
    216
    Likes Received:
    0
    Hi
    you are using the correct transformer? Z is run on 8V DC not AC.
    Tony