turbo nimbus heli

Discussion in 'RC Aircraft & Watercraft' started by ewendell, Apr 7, 2004.

Thread Status:
Not open for further replies.
  1. ewendell

    ewendell Member

    Joined:
    Apr 5, 2004
    Messages:
    17
    Likes Received:
    0
    I hooked up my transmitter, put in the channel crystals,turned on transmitter, also receiver, all I get are flashing lights, what's wrong?
  2. Quack

    Quack New Member

    Joined:
    Jun 4, 2004
    Messages:
    2
    Likes Received:
    0
    Yeah i have the same problem.

    It flashes red to green and back again.
    No response from the servo's or the throttle. Very strange.

    I am thinking its a battery fault, i am yet to test with a decent power source.
  3. Quack

    Quack New Member

    Joined:
    Jun 4, 2004
    Messages:
    2
    Likes Received:
    0
    I tried with another 4ch receiver and controller combo (from a plane), and all works just fine.

    (the flashing light is on the gyro unit, not the receiver, and it turns solid green and all works now).
  4. ewendell

    ewendell Member

    Joined:
    Apr 5, 2004
    Messages:
    17
    Likes Received:
    0
    how did you set it up with new stuff and how does it fly, which channel for what
  5. scar

    scar New Member

    Joined:
    Jun 10, 2005
    Messages:
    6
    Likes Received:
    0
    Was the transmiter turned on first? I know with my heli ( not the same one) that my gyro blinkes if I don't turn my transmiter on first, and that's when you adjust the sensitivity of the gyro.
Thread Status:
Not open for further replies.