RC18T problem

Discussion in 'RC Offroad Forum' started by Justin_E, Dec 27, 2004.

Thread Status:
Not open for further replies.
  1. Justin_E

    Justin_E Member

    Joined:
    Jun 21, 2004
    Messages:
    342
    Likes Received:
    0
    whenever i run it with the antenna down and its like 8 feet away, it like spazzes out and goes on its own and stuff. But with the antenna up if you get it a little farther away it kinda does the same thing....wats goin on?
  2. bandit1

    bandit1 Member

    Joined:
    Mar 23, 2003
    Messages:
    328
    Likes Received:
    0
    uh, how far is a little more away??? that could easily be its limit.
  3. dj6666969

    dj6666969 Active Member

    Joined:
    Feb 6, 2004
    Messages:
    1,284
    Likes Received:
    0
    this is the same for any rc. If the antenna is down it won't go far if it is up it will. Same thing as it is with your gt just don't try it because the nitor does more damage :D
  4. Justin_E

    Justin_E Member

    Joined:
    Jun 21, 2004
    Messages:
    342
    Likes Received:
    0
    like at 20 feet it goes on its own and stuff with the antenna up
  5. rockn82

    rockn82 Marx Brother

    Joined:
    Nov 6, 2002
    Messages:
    346
    Likes Received:
    0
    Make sure your batteries are full in the Tx and the battery for the car is full because that one controls the Rx as well as powers the car. If the battery in the vehicle gets low then your reception/range will also change. If it is neither and your sure, then call AE and see if they are having any trouble. If not get the address to send it to and send it back to them for warranty. Your range should be comparable to that of a normal radio. At least 200ft on the skimpy side.
  6. Justin_E

    Justin_E Member

    Joined:
    Jun 21, 2004
    Messages:
    342
    Likes Received:
    0
    ok thanks
  7. dj6666969

    dj6666969 Active Member

    Joined:
    Feb 6, 2004
    Messages:
    1,284
    Likes Received:
    0
    LMAO Justin I just broke my first part, I should say 2 parts lol. I was running it at my Local B&G club and broke the rear hub andfront steering arm, 4 bucks for both all in 1 package :D! I am wondering if the 18t is gonna be like the mini t when it first came out, hard to get parts. What do you all think?
  8. Justin_E

    Justin_E Member

    Joined:
    Jun 21, 2004
    Messages:
    342
    Likes Received:
    0
    actually not really hard to find stock parts, allready saw them in this awesome new HS, but I was asking about upgrades and they said they would take a while b4 all of them come in. Im waiting for them to get extended body posts so I can fit the Losi Hummer Body on :)
  9. dj6666969

    dj6666969 Active Member

    Joined:
    Feb 6, 2004
    Messages:
    1,284
    Likes Received:
    0
    I just picked up the parts for 4 bucks and the trany gears for 3 bucks so im set for awhile!
  10. Justin_E

    Justin_E Member

    Joined:
    Jun 21, 2004
    Messages:
    342
    Likes Received:
    0
    cool. lol we are getting a little off topic
  11. dj6666969

    dj6666969 Active Member

    Joined:
    Feb 6, 2004
    Messages:
    1,284
    Likes Received:
    0
    did you get your problem fixed yet?
  12. Justin_E

    Justin_E Member

    Joined:
    Jun 21, 2004
    Messages:
    342
    Likes Received:
    0
    havnt been able to, its been pouring all week and suppose to keep on til like monday
  13. dj6666969

    dj6666969 Active Member

    Joined:
    Feb 6, 2004
    Messages:
    1,284
    Likes Received:
    0
  14. Elvis

    Elvis New Member

    Joined:
    Jan 5, 2005
    Messages:
    7
    Likes Received:
    0
    did u cut the antenna? if u did...that would be the problem
  15. Justin_E

    Justin_E Member

    Joined:
    Jun 21, 2004
    Messages:
    342
    Likes Received:
    0
    i have the HPI titanium attenna on it...but the hobby shop said this would work......but it just started doing this.......
  16. dj6666969

    dj6666969 Active Member

    Joined:
    Feb 6, 2004
    Messages:
    1,284
    Likes Received:
    0
    just to see if it is that attenna take it off and put the stock 1 on it or if you don't have it take the 1 from your gt and try that
Thread Status:
Not open for further replies.