Mini t Servo doesent work right

Discussion in 'RC General & Getting Started' started by dj6666969, Apr 10, 2004.

Thread Status:
Not open for further replies.
  1. dj6666969

    dj6666969 Active Member

    Joined:
    Feb 6, 2004
    Messages:
    1,284
    Likes Received:
    0
    OK I have a Losi Mini t and I am haveing some serious problems with it. When I plug a battery into it it the steering servo will work for about 10 seconds and then slowly stop and then it wont move any more. I cant seem to figure out what is goin on. Can any 1 help me>
  2. mastmec

    mastmec Member

    Joined:
    Jan 24, 2004
    Messages:
    658
    Likes Received:
    0
    Disconnect the linkage from the servo and check for any binding, it could be overheating and shutting down or it may be bad.
  3. dj6666969

    dj6666969 Active Member

    Joined:
    Feb 6, 2004
    Messages:
    1,284
    Likes Received:
    0
    I took it to my local HS and they tried a new servo and it still dident work so I think its fryed
  4. monsterrcbuilder04

    monsterrcbuilder04 Active Member

    Joined:
    Feb 13, 2004
    Messages:
    1,636
    Likes Received:
    0
    a wire might have just came unsoldered in the reciever or theres a short.
  5. dj6666969

    dj6666969 Active Member

    Joined:
    Feb 6, 2004
    Messages:
    1,284
    Likes Received:
    0
    I looked over everthing and in the end I ended up buying all new electronics (servo and esc/reciver)
Thread Status:
Not open for further replies.