i need help please

Discussion in 'RC General & Getting Started' started by imfast, Jan 4, 2004.

Thread Status:
Not open for further replies.
  1. imfast

    imfast Member

    Joined:
    Dec 9, 2003
    Messages:
    110
    Likes Received:
    0
    i just got a mini-t and a 6 cell battery pack for it...so i go and charge it then i went and drove it for a while then the motor stoped working it gets power to it but it wont turn plz help me thank you for advise..
  2. timrock

    timrock Active Member

    Joined:
    Nov 22, 2003
    Messages:
    1,114
    Likes Received:
    0
    how do you know it gets `power` to it?
  3. imfast

    imfast Member

    Joined:
    Dec 9, 2003
    Messages:
    110
    Likes Received:
    0
    my dad put one of those power testing things on it and it is getting 7.0 volts to it
  4. UltimateStampede

    UltimateStampede Member

    Joined:
    Aug 2, 2003
    Messages:
    47
    Likes Received:
    0
    that is exactly what happened to my 8.4v for my pede. you have a bad cell in the batt pack. i know its new but thats life or it was returned and put back on the shelf for sale.
  5. imfast

    imfast Member

    Joined:
    Dec 9, 2003
    Messages:
    110
    Likes Received:
    0
    i got it fixed but now i need a new motor i was running it and then the motor got very hot and now i cant turn the shaft at all with my hands it sucks i have to get a better motor i guest...any suggestions on the motor for the mini-t with a 6 cell battery
  6. timrock

    timrock Active Member

    Joined:
    Nov 22, 2003
    Messages:
    1,114
    Likes Received:
    0
    sounds like your motor is shot.could be somthing in it like a pebble or somthing but most likly it is shot.comuntater propably pealed away from the shaft and is locking it up.
  7. imfast

    imfast Member

    Joined:
    Dec 9, 2003
    Messages:
    110
    Likes Received:
    0
    yep its locked up for sure
  8. timrock

    timrock Active Member

    Joined:
    Nov 22, 2003
    Messages:
    1,114
    Likes Received:
    0
    get a new motor.i cant be much help with that.sorry.i have alot of experince with 1/10 scale. not much of the scale of your car.
  9. imfast

    imfast Member

    Joined:
    Dec 9, 2003
    Messages:
    110
    Likes Received:
    0
  10. UltimateStampede

    UltimateStampede Member

    Joined:
    Aug 2, 2003
    Messages:
    47
    Likes Received:
    0
    try to take the motor apart anyway and see if you can fix it yourself.
  11. imfast

    imfast Member

    Joined:
    Dec 9, 2003
    Messages:
    110
    Likes Received:
    0
    all ready tried but it is locked up and i cant fix that i tried
Thread Status:
Not open for further replies.