anyone need help with something ask here

Discussion in 'RC Offroad Forum' started by mpracing, Nov 11, 2002.

  1. Overdrive789

    Overdrive789 New Member

    Joined:
    Oct 8, 2003
    Messages:
    22
    Likes Received:
    0
    Yo,

    What is the best battery to use with a Trinity Chameleon 2 Pro electric motor?? it has to be under 100$$.

    Thanks
  2. timrock

    timrock Active Member

    Joined:
    Nov 22, 2003
    Messages:
    1,114
    Likes Received:
    0
    Overdrive789,what kind of charger do you have?
  3. timrock

    timrock Active Member

    Joined:
    Nov 22, 2003
    Messages:
    1,114
    Likes Received:
    0
    wayendraton, i would remove the pull start and get an electric starter.the pull start you have on it sounds like it is the wrong one.also pull starts rob power from the engine making your car slower.
  4. mooserman75

    mooserman75 New Member

    Joined:
    Jan 11, 2004
    Messages:
    4
    Likes Received:
    0
    i have an ultra lx pro with a force .26 what are the first upgrades i should get?
  5. Overdrive789

    Overdrive789 New Member

    Joined:
    Oct 8, 2003
    Messages:
    22
    Likes Received:
    0
    I have a peise of junk MRC super brain 809
  6. timrock

    timrock Active Member

    Joined:
    Nov 22, 2003
    Messages:
    1,114
    Likes Received:
    0
  7. Overdrive789

    Overdrive789 New Member

    Joined:
    Oct 8, 2003
    Messages:
    22
    Likes Received:
    0
    thanks timrock!
  8. dirtovallMaster

    dirtovallMaster New Member

    Joined:
    Jan 17, 2004
    Messages:
    9
    Likes Received:
    0
    nice battery for a Nicad but NiMH batteries are better.
  9. A J G 3 6 6

    A J G 3 6 6 Member

    Joined:
    Nov 20, 2003
    Messages:
    199
    Likes Received:
    0
    I have an e-rustler,and I was runing it outside in the melted snow...and I went through this big puddle and a couple seconds later it just stoped,then it just went haywire. I brought it inside,dried things off. tried to run again and its just keeped going haywire.After like 5 seconds i shut it off. I felt the ESC and it was burning hot.What could be wrong with it? I need help,thanks
  10. mxking171

    mxking171 Member

    Joined:
    Dec 17, 2002
    Messages:
    66
    Likes Received:
    0
    hey man i have an electric stampede and i did the same thing i dont no how rich u are but with my stamp when i went through the water it went haywire and started to smoke then i dried it of and i had forwards and no reverse but anyways if it doesnt work im going to say buy an esc that will fit it.
  11. dirtovallMaster

    dirtovallMaster New Member

    Joined:
    Jan 17, 2004
    Messages:
    9
    Likes Received:
    0
    how fast was your HPI Savage going when it hit the tree?5MPH? or 50MPH?
  12. timrock

    timrock Active Member

    Joined:
    Nov 22, 2003
    Messages:
    1,114
    Likes Received:
    0
    your reciever got wet that would be why it went `haywire`
    most ESCs are sealed up much better than most recievers.
    What kind of ESC and Reciver?
  13. mxking171

    mxking171 Member

    Joined:
    Dec 17, 2002
    Messages:
    66
    Likes Received:
    0
    my savage was going 2nd gear full throtle stuck wide open and hit a tree are u dising it?
  14. timrock

    timrock Active Member

    Joined:
    Nov 22, 2003
    Messages:
    1,114
    Likes Received:
    0
    No.it is just that your story doesnt say how fast it was going when it hit the tree or how far away from the tree it was when the throttle stuck open.it says `this shows how tuff the Savage is`but it doesnt show anything.thought i should let you know.
  15. timrock

    timrock Active Member

    Joined:
    Nov 22, 2003
    Messages:
    1,114
    Likes Received:
    0
    Dirtovallmaster what do you race electric or nitro?
  16. Jag

    Jag New Member

    Joined:
    Jan 18, 2004
    Messages:
    22
    Likes Received:
    0
    I just bought a Kyosho Ultima Pro buggy, and need the gear cover housing for it. At tower hobby, they have gear cover housings for EP ultima sports, EP ultima ST R and the EP sport buggy. But none for the Ultima Pro. Will any of the other ones fit? OR is there some other style that fits. I've looked around as best I can, ebay etc, but not found one yet for the Ultima Pro. I'm a newbie here, so any advice is greatly appreciated. Also need a wing and wing stay for it, if you have any suggestions there as well.
    Jaggy
  17. Overdrive789

    Overdrive789 New Member

    Joined:
    Oct 8, 2003
    Messages:
    22
    Likes Received:
    0
    I also went through the melted snow, and i think i might have gotten water in my esc, and my receiver. wat would be the best way to dry these up??
  18. timrock

    timrock Active Member

    Joined:
    Nov 22, 2003
    Messages:
    1,114
    Likes Received:
    0
    the recievers get wet much easier than most ESC.some guys put thier recivers in a balloon in case that happens.but if it got wet, first thing is turn it off as fast as possible.you can open it and put a hair dryer to it to dry it out faster but eventualy it will dry on its own.if you put a hair dryer to it,make sure you dont heat it up.just keep it away from it enough just to let the blown air hit it.
    also,it wont hurt anything if the electronics get wet,it is just when you have voltage to them while they are wet.that can ruin them.
  19. Trashcanoccupant449

    Trashcanoccupant449 Member

    Joined:
    Dec 11, 2003
    Messages:
    165
    Likes Received:
    0
    I just soldered the capacitors and diode to a Tower Hobbies speed secret 14t quad motor and hooked it up to my Duratrax streak ESC and it makes an odd humming noise when its in neutral. The ESC doesn't have any performance issues (switching from forward to brake and glitching) but I was just wondering if the humming is anything to be worried about. The motor only hums when it is in neutral, when I apply the throttle or the brake, the motor sounds fine.
  20. timrock

    timrock Active Member

    Joined:
    Nov 22, 2003
    Messages:
    1,114
    Likes Received:
    0
    it could be a simple throttle adjustment on your transmitter.